Cómo instalar versiones antiguas del iOS SDK

Cuando se instala una nueva versión de xcode se elimina la versión anterior y no se pueden utilizar los SDK anteriores.

Para instalar un SDK anterior primero hay que conseguirlo :) 

Yo necesitaba el 5.1 y lo tenía en mi Time Capsule. Pero sino, acá hay una página en la cual hay varios SDKs.

Y para "instalarlo" hay que copiarlo a una carpeta específica: /Applications/xcode/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs

That's it ;)